Welcome to Flight1.com! We have many great aviation products for FSX/FS9 and P3D.
Most of our products are available by download for immediate purchase.



 Search

FS2004 (FS9) Limited Support Notice

Flight1 still has many products that we sell that are FS2004 compatible. Although we sell these, FS2004 is quite old, and may not run on Windows 10. We can only offer very limited support as described below for FS2004 products, even if you are running on a non-Windows 10 machine.

We can only provide support for product validation issues relating to our ecommerce platforms (for example lost product keys or account login issues). We cannot officially support connection to our servers from any operating system other than Windows 10. If you do not have Windows 10 (XP, Vista, 7, 8) and you have trouble connecting to our servers using our applications, this could be because you do not have TLS 1.2 enabled which is a required modern standard. Read here for more information on TLS 1.2. You may be able to connect after reading this information.

We will not be able to offer any actual technical support on the product itself, or do additional research on technical issues that require testing, as we no longer have FS2004 installed on our development machines.

Please be aware of this before you make your purchase.

You are welcome to post in the appropriate support forum regarding any of your FS2004 product issues. Another forum member may have an answer. You may also used the forum search function as your issue may have already been addressed in an earlier topic.




Copyright © 2020 Flight One Software, Inc. all rights reserved.
How to Contact Us or read our Terms of Service.